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CHAPTER 6: DESKTOP PUBLISHING 

Introduction to Desk Top Publishing 
Desktop publishing (abbreviated DTP) is the creation of documents using page layout skills on a 

personal computer primarily for print. Desktop publishing software can generate layouts and 

produce typographic quality text and images comparable to traditional typography and 

printing.  

The term Desktop Publishing (-or DTP for short) covers a broad range of activities. In it's widest 

sense, it can mean anything concerned with creating a printed document on a desktop PC. 

Desktop Publishing [is] anything where you need precise control over the position of text and/or 

graphics on the printed page. DTP software is an enhanced combination of word processor and 

graphics software that allow manipulation of text, graphics and typefaces on screen before finally 

printing a design on paper 

However, most simple documents can be handled by a Word Processor and do not require the 

more advanced facilities of a dedicated DTP application and so we normally refer to Desktop 

Publishing as anything where you need precise control of the position of text and/or graphics on 

the printed page. Typical DTP candidates include: 

 Books containing diagrams 
 Newsletters 
 Advertising Flyers 
 Leaflets 
 Anything that requires multi-column output 

Note: graphics falls into five major categories; photographs, illustrations, texture, line drawings 

and cartoon or caricature 

A DTP package allows the different types of graphics be incorporated in a publication 

Types of DTP software 

DTP software may divide into two: 

1. Layout based software – combines text and graphics to create publication. Single page 

artistic layouts or short documents that combines text and graphics requires a page layout 

tool that provides extensive typographic control and graphic loading capabilities which is a 

feature of layout based software. Typical projects for page layout tools include fliers, posters 

and business cards 

i.e. – MS Publisher, Page maker 
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2. Print and draw software – provides an environment for drawing and manipulating graphics. 

There are two main types of graphics packages 

a) Vector graphics – use/create vector image. Vector image are made up of individual, 

scalable objects defined by mathematical equations. Objects here consist of lines, curves 

and shapes with editable attributes as color, fill and outline.       

i.e. – Corel draw and Illustrator  

b) Bitmap graphics – use/create bitmap image. Bitmap image also called raster image are 

made up of pixels. Pixels are picture elements made up of tiny dots of individual color that 

make up/define an image.                                                               

 i.e. – Photoshop and MS paint 

Microsoft Publisher 
Microsoft Publisher is an entry-level desktop publishing application from Microsoft, differing 

from Microsoft Word in that the emphasis is placed on page layout and design rather than text 

composition and proofing 

Publisher is included in higher-end editions of Microsoft Office, reflecting Microsoft's emphasis 

on the application as an easy-to-use and less expensive alternative to the "heavyweights" with a 

focus on the small business market where firms do not have dedicated design professionals 

available to make marketing materials and other documents. However, it has a relatively small 

share of the desktop publishing market, which is dominated by Adobe Applications.  

In Microsoft Office 2007, while most of Microsoft Office apps adopted ribbons in their user 

interface, Publisher retained its toolbars and did not adopt ribbons until the next version 

Publisher Basics and Feature 

Microsoft Publisher 2007 is a desktop publishing program that can be used to create a variety 
of publications. Using Publisher, you can easily create business cards, greeting cards, 
calendars, newsletters and much, much more.  
Unlike the other programs in Microsoft Office 2007, Microsoft Publisher 2007 uses the Microsoft 
Office Toolbar and a Menu system in place of the Microsoft Office Ribbon. 
 
Some Useful Definitions: 

Frame – Most publications are divided into several different areas called frames. A frame can 
contain a variety of objects such as graphics, tables, or text boxes. Frames can be resized, 
moved and manipulated to suit your needs. 

 

Handles – When you click on a frame, small circles appear around the edge of the frame. 
These are called handles. You can click and drag on the handles to resize your frame. 
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Template ‐ A Template is a tool used in Publisher to help you easily create basic 
publications. The template has a set of pre‐chosen design styles that you can use 
as it is or customize as you see fit. 

 

Opening Publisher 
 
To Open Publisher either: 
 

Double click on the Microsoft Publisher Icon on your desktop, OR 
 

‐OR 
 

Click on Start in the lower left hand corner of your desktop, move up to 
Programs, and then click on Microsoft Publisher 

 
 
Creating New Publications with Publisher. 
When you first open Publisher, Publisher offers you a number of different publication types 
to start with. 

 

Click on one of the publication types in the main window or in the list on the left side of the 
main window to view a list of templates that will walk you through the process of making basic 
design choices for your publication. These choices include color schemes, font styles, and more. 
 

Examples  
To Create a Calendar: 
 
1. Open Microsoft Publisher by double clicking the icon on the desktop or finding it under 

the start menu.  
 
2. Click on Calendars from the main window or the list on the left. A selection of pre‐ 

designed templates appears for you to choose from.  
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3. Click on one of the pre‐designed templates that you like. It will appear at the top of the 
area on the right side of the page.  

 
4. You can either stick with the default design choices that are part of the template, or you can 

customize them by clicking the downward pointing arrow to the right of a design section 
and choosing any of the options provided by clicking on it.  

 
5. Click on the Set Calendar Dates button and choose the period of time that you would 

like your calendar to cover.  
 
6. Click on Create at the bottom to create your caledar.  

 

Now that you have made your basic calendar selections, it is time to further customize the 
publication. 

 

Creating a Business Card 
 

1. Open Microsoft Publisher by double clicking the icon on the desktop or finding it under 
the start menu.  

 
2. Click on Publications for Print then Business Cards, and finally Accent Box 

Business Card.  
 

3. In the personal information form that opens, 
enter your own contact information and click on 
OK. (If you accidentally close your personal 
information and you want to edit it further, click 
on the Edit Menu and  
Personal Information to retrieve the form.)  

 
4. In the task pane on the left side of the window, 

you are given different options you can adjust. 
As you click on the different steps at the top of 
the task pane, the options change on the lower 
part of the task pane.  

 
5. Click on Business Card Options.  

 
a. Choose to Include a logo.  

 
b. Choose the traditional Landscape 
orientation  

 
c. Choose to have Multiple copies per 

sheet  
 

6. Click on Publication Designs.  
 

a. Leave the selected Accent Box.  
 

b. Click on Color Schemes and select the desired color scheme.  
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7. Click on Font Schemes and select the desired font scheme.  
 

Now that you have completed the Business Card Wizard, you can customize the 
business card. Change the format or insert additional clip art, if you wish. 

 
Creating a Personalized Greeting Card 

 

1. Open Publisher by double clicking the icon on the desktop or finding it under the start 
menu.  

 
2. Click on Publications for Print  Greeting Cards  Birthday  Birthday Card  

72  
 

3. Click on Greeting Card Options  
 

a. Select Greetings Bar.  
 

b. Select Full Verse  
 

c. Click on Select a suggested verse. A dialog 
box will open click on a verse on the left 
side and on the right side it will show you 
the front message and the inside message. 
Select the verse you would like to use and 
click on OK.  

 
i. 

 
• Click on Page Options  

 
 Choose the Quarter page side fold 

option.  
 

• Click on Card Gallery  
 

 Leave Birthday 72 selected.  
 

• Click on Color Schemes  
 

 Select the desired color scheme.  
 

• Click on Font Schemes  
 

 Select the desired font scheme.  
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Now that you have completed the Greeting Card Wizard, you can customize the 
greeting card. 

 

At the bottom of the screen are sheets with numbers on them (1, 2, 3, 4). Click on 1 to see the 

front of the card. Click on 2 or 3 to see the inside of the card. Click on 4 to see the back of the 

card. 

Customizing a Publication (Working with text and objects) 

Working with Frames 
 
Each publication is composed of different frames, such as text frames, picture frames, table 
frames, and shape/object frames. Click on different areas of the calendar to identify the 
different frames. Handles, little circles on the corners and sides of the frame will appear. The 
handles help show which frame you have selected. They are also used in resizing frames. 

 

Moving Frames 
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Deleting Frames  
1. Right click on the frame that you would like to delete.  

2. Select Delete Object from the list of choices.  

 

Formatting Text  
1. Click in a text frame.  

2. Begin typing.  

3. Click and drag over the text you typed to select it for formatting changes.  

4. Use the Formatting Toolbar or click on Format Font to make changes to the text‘s 

appearance 

 

Undoing Changes  

Creating a publication often involves trial and error. Unlike many of Microsoft Office‘s other 

applications, in Publisher you cannot preview what a change is going to look like until you apply it.  

To undo actions, click on the undo button on the standard toolbar or click on Undo in the Edit Menu.  

Inserting Additional Text Frames  
1. Click on Text box from the Insert Menu  

2. Click and drag over an area of the publication.  

3. Type the text you want to appear.  

 

Inserting Clip Art  

If you want to change the picture in an existing picture frame,  
1. Right click on the picture and select Delete Object.  

2. Click on Insert Picture Clip Art.  

3. A Clip Art search interface will open in the task pane.  

4. Enter a search term and press Go.  

5. You can choose to limit the search to a particular collection or a particular media type.  

6. Once you discover the desired clip art, click on it to insert it.  

 
Notice that the clip art has a drop down arrow next to it. If you click on the drop down arrow other 

options present themselves. You can click on Find Similar Style for clip art of similar design. You can 

click on Preview/Properties to view the original size of the clip art and what keywords were used to 

classify the picture. 
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Create a table 

Create a table and type text into it  

1. On the Objects toolbar, click Insert Table . 

2. Click inside your publication.  

The Create Table dialog box will appear. 

3. Select the options you want, and then click OK. 

4. Size your table.  

How?  

Select the table, position the mouse pointer over a selection handle until you see the 

Resizer icon, and then drag to resize the table. 

5. In the table, click the cell where you want to add text, and then start typing.  

To add text to another cell, click inside that cell. 

Each cell expands to fit your text, unless you lock the table size by clearing the check 

mark next to Grow to Fit Text on the Table menu. 

 

Create a table from existing Microsoft Publisher text  
1. If the text is in a table, select the cells you want. 

If the text is in a text box, make sure there's a tab or comma between each entry in a row, 

and a paragraph mark at the end of each row. 

2. Highlight the text. 

3. Right-click the highlighted text, and then click Copy. 

4. On the Edit menu, click Paste Special. 

5. In the As list, click New Table. 

6. Click OK. 

Create a table by using text from another program  
1. Open the program that contains the text you want. 

If the text isn't already in a table, press TAB between each entry within a row of text, and 

press ENTER at the end of each row. 

2. Select the text, and then press CTRL+C to copy it.  

3. Open your Publisher publication and go to the page you want to change. 

4. On the Edit menu, click Paste Special. 

5. In the As list, click New Table. 

6. Click OK. 
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Note: Depending on how your text was formatted in the other program, you might want 

to reformat the text after it becomes a Publisher table. 

 

Working with Color Schemes 
A color scheme is a set of colors that you group together to use with your publication. You may 

want to create a color scheme for specific projects or simply to maintain and quickly access the 

colors you use most frequently. A color scheme can also be used to develop a consistent, 

polished look for your publication. Colors in a color scheme may be applied to any element of 

the publication. This document contains sections on the following topics: 

 Creating a Custom Color Scheme 
 Applying a Color Scheme 
 Using the Colors of a Color Scheme 

Creating a Custom Color Scheme 

Your color scheme will most likely consist of colors that complement each other as well as some 

that provide contrast. You can create and save multiple schemes for use in a variety of 

publications. 

1. Create or open a publication 

2. On the Publisher task pane, click COLOR SCHEMES  

OR 
From the Format menu, select Color Schemes... 

The Color Schemes task pane appears. 
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3. At the bottom of the task pane, click CREATE NEW COLOR SCHEME...  

The Create New Color Scheme dialog box appears.  

 
4. In the Scheme colors section, from the New pull-down lists, select the desired colors 

HINTS:  

To see a larger selection of colors, click MORE COLORS... 

The Preview section to the right shows a dynamic preview of how your color changes 

will affect images and shapes in your document. 

The Sample section to the right shows a dynamic preview of how your color changes will 

affect text in your document.  

5. In the Color scheme name text box, type a name for your color scheme  

6. Click SAVE 

Your color scheme now appears as a choice in the Apply a color scheme scroll box. 

Applying a Color Scheme 

Publisher has a number of predefined color schemes. These color schemes affect text, images, 

and shapes in your document. You can apply one of these or a custom scheme that you have 

created. Custom color schemes appear in their own section in the list alphabetically according to 

the name you assigned the color scheme. 

1. Create or open a publication 

2. On the Publisher task pane, click  

OR 
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From the Format menu, select Color Schemes... 

The Color Schemes task pane appears. 

3. From the Color Schemes list, select the desired color scheme 

The color scheme is applied. 

Using the Colors of a Color Scheme 

Once you have applied a color scheme to your publication, the colors of the scheme are easily 

accessible from the FONT, LINE, or FILL COLOR buttons on the Formatting toolbar. The 

colors of the color scheme appear as the first row of colors in the color palette accessed from 

these buttons. 

NOTES:  

The FONT button does not appear unless text is highlighted. 

You can apply separate colors to the border and to the inside of an object.  

1. Select the object or text to which you want to apply color   

2. To apply color to text, on the Formatting toolbar, click the next to FONT COLOR » 

select a color 

To apply color to only the border of your object, click the next to LINE COLOR » 

select a color 

To apply color to only the inside of your object, click the next to FILL COLOR » 

select a color 

The color is now applied. 

 

Saving Your Publication  

There are two basic ways to save your publication  

Point and click on the save icon on your toolbar, or  

‐OR  
1. Click on the File Menu and Save As.  

2. When the Save As Dialogue Box appears Click Browse and find the location on your computer 
where you would like the file saved.  

3. Type the name of your publication in the File Name field.  

4. Click on the Save button  

 

Change page size, paper size, or page orientation 

Page size refers to the area of your publication. Paper, or sheet, size is the size of the paper used 

for printing. 

Orientation refers to the portrait (vertical) or landscape (horizontal) layout.  
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Choose a page size 

1. Select the Page Design tab. 

 

2. In the Page Setup group, select Size and click the icon that represents the page size that 

you want. For example, click Letter (Portrait) 8.5 x 11". If you don‘t see the size you 

want, either click More Preset Page Sizes or click Create New Page Size to create a 

custom page size. For more information on creating new custom page sizes,  

Tip:  Using Publisher 2007? Go to the Format Publication task pane, then click Change 

Page Size. In the Page Setup dialog box, click the icon that represents the page size that 

you want. 

Create a custom page size 

1. Select the Page Design tab. 

2. In the Page Setup group, select Size, then Create New Page Size. Under Page, enter the 

width and height you want. 

Tip:  Using Publisher 2007? Go to the Format Publication task pane, then click Change 

Page Size. In the Page Setup dialog box, under Page, enter the width and height you 

want. You can also select a publication type, such as Posters, click Create custom page 

size, and then enter the width and height that you want under Page. In the Custom Page 

Size dialog box, you can name your custom page size and specify the layout type and 

margins that you want. 

Change the paper size 

The printer that you use determines the paper sizes that you can print on. To check the range of 

paper sizes that your printer can print on, consult the manual for your printer, or view the paper 

sizes that are currently set for your printer in the Print Setup dialog box. 

Tip:  Using Publisher 2007? View the paper sizes that are currently set for your printer in the 

Print Setup dialog box. 

To print your publication on sheets of paper that match the publication page size, be sure that the 

page size and the paper size are the same. If you want to print your publication on a different size 

of paper  — for example, to create a bleed or to print multiple pages on one sheet — change only 

the paper size. 
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1. On the File menu, click Print Setup. 

2. In the Print Setup dialog box, under Paper, select the size of paper that you want from 

the Size list.  

Tip:  Using Publisher 2007? On the File menu, click Print Setup. In the Print Setup dialog 

box, under Paper, select the size of paper that you want from the Size list. 

Change the orientation of the page 

You can change the orientation of your page to and from Portrait and Landscape.  

1. Select the Page Design tab. 

 

2. In the Page Setup group, select the Orientation drop-down menu and select either 

Portrait or Landscape. 

Tip:  Using Publisher 2007? In the Format Publication task pane, click Change Page Size. In 

the Page Setup dialog box, select the page size that has the orientation you want. 

Change the ruler measurements 

Need to measure your document in centimeters, not inches? You can change your ruler to 

centimeters, picas, points, or pixels, along with inches. 

Click File > Options > Advanced and scroll to the Display settings. Look for Show 

measurements in units of, and change the units. 
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Tip:  Using Publisher 2007? Click Tools > Options > General tab. Look for Measurement 

units and pick the units you want. 

Printing Your Publication  
There are two basic ways to print your publication:  

Click on the print icon on your toolbar . This will print one copy of your publication with the 
default print options.  

‐OR  
1. Click on the File Menu and click Print.  

2. When the print window appears, select the desired number of copies and choose any other 
printing options you want.  

3. Click OK.  
 

Import a Word document 
You have a Word document, but you need to add graphics — and you want to take advantage of 

the superior graphics-handling capabilities of Publisher. Or you want to convert a report that you 

typed in Word into a publication so  that it can be branded the same way as all your other 

business publications. 

Fortunately, converting Word documents that were created in Microsoft Office Word into 

Publisher publications is easy. All you have to do is choose the publication design that you want 

and then locate the Word document that you want to convert. 

1. Start Publisher.  

2. In the Publication Types list, click Import Word Documents. 

To find this option: In Publisher 2007, look under Popular Publication Types. 

3. Click the design that you want, and then click Create. 
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4. In the Import Word Document dialog box, locate and click the file that you want to 

import, and then click OK. 

5. Review the publication to make sure that everything looks the way that you want, and 

then save the publication. 

Insert a file 
1. In your publication, create a text box (Insert > Draw Text Box) if you have not already 

done so.  

2. In the text box, click where you want to paste the text. 

3. On the Insert menu, click Insert File (in Publisher 2007, click Text File). 

4. Locate and click the file that you want to import.  

5. Click OK.  

Note: You may need to resize the text box to make the text fit the way you want. 

Add, change, or remove a border in Publisher 
You can add a line border of any color or thickness, a predesigned border, or a custom border to 

a page, text box, AutoShape, picture, or around a group of objects in your publication. 

You can also use a picture that is designed to be a border. For example, you can insert a page 

border clip from Clip Art and Media on Microsoft Office Online, and then change the size to fit 

the page or object that you want to add a border to. 

If the page, text box, AutoShape, picture, or group of items already has a border, you can change 

or remove it. 

Add a border to a page 

To add a border to a page, draw a rectangle around the page and then add the line or predesigned 

border you want. To add a border to all the pages in your publication, add the border to a master 

page, and then apply the master page to the pages in your publication.  
Determine your desktop printer's nonprintable region 

1. Open Microsoft WordPad. 

how  
o On the Windows taskbar, click the Start button, point to All Programs, point to 

Accessories, and then click WordPad. 

2. On the File menu, click Page Setup. 

3. Set the Left, Right, Top, and Bottom margin values to zero. The margins will be reset 

automatically to the minimum margin that is supported by the printer. 

4. Note the minimum margins. 

To make sure that all sides of the border will print, you can preview your publication by clicking 

Print Preview on the File menu. 
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Add a border to a page 

1. Select the page that you want to add the border to. 

2. On the Objects toolbar, click Rectangle  , and then drag on the page to draw a 

rectangle the size that you want the page border, for example to the page margins. 

3. Select the rectangle, and then click AutoShape on the Format menu. 

4. Click the Colors and Lines tab. 

5. Do one of the following: 

Add a line border of any color or width  
a. Under Line, choose the color and line options you want. 

b. To add the border equally to both the inside and the outside of the rectangle, 

rather than to the inside only, clear the Draw border inside frame check box. 

This helps to prevent the border from overlapping objects that are located inside 

of the rectangle. 

Add a predesigned pattern border  
c. Click Border Art. 

d. In the Available Borders list, click the border you want. 

Add a custom border  
You can create a custom border from clip art, a picture file, a scanned photograph or 

other bitmap, or a picture that you created in a drawing program. Your custom border 

will be stored with the Microsoft Office Publisher 2007 border art.  

Note: The picture file that you use for a custom border must be smaller then 64 kilobytes 

(KB) in size and must not include any text. 

e. Click BorderArt. 

f. In the BorderArt dialog box, click Create Custom. 

g. In the Create Custom Border dialog box, to add a picture from a file that is 

located on your computer's hard disk without adding it to the Microsoft Clip 

Organizer, clear the Use Clip Organizer to select the picture check box. 

h. Click Select Picture. 

i. In the Insert Picture dialog box, browse to the location that contains the picture 

you want, click the picture, and then click Insert. 

j. In the Name Custom Border dialog box, type a name for your custom border, 

and then click OK. 

If the file size of the picture that you select is too large (greater than 64 KB), or if 

the picture contains text, you may receive an error message, and the border may 

not be created. If this occurs, repeat step 2 through step 5 to select a picture that 

has a smaller file size. 
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Add a clip art border 

You can quickly create a border with clip art. 

1. Select the page that you want to add the border to. 

2. On the Insert menu, point to Picture, and then click Clip Art. 

3. In the Clip Art task pane, type page borders in the Search for box, and then click Go. 

4. In the Clip Art task pane, click the border you want. 

5. In your publication, position the mouse pointer over one of the sizing handles on the 

border, and then drag the handle to resize the border. 

6. If the border has a solid fill that is covering the contents of your page, select the border, 

point to Order on the Arrange menu, and then click Send to Back so that the contents 

of your page show in front of the border fill. 

Add a border to a text box, an AutoShape, a picture, or an object 

You can add a line border to a text box, an AutoShape, a picture, or an object. You can also add 

a predesigned or custom border to a text box, a picture, or a rectangle (but not to other 

AutoShapes, such as a circle or an oval). 

1. Select the text box, AutoShape, picture, or object that you want to add the border to. 

2. On the Format menu, click Text Box, AutoShape, Picture, or Object. 

3. Click the Colors and Lines tab. 

4. Do one of the following: 

Add a line border of any color or width  
a. Under Line, choose the color and line style options you want. 

b. To add the border equally to both the inside and the outside of the rectangle, 

rather than to the inside only, clear the Draw border inside frame check box. 

This helps to prevent the border from overlapping objects that are located inside 

of the rectangle. 

Add a predesigned pattern border  
c. Click BorderArt (not available if you have selected an AutoShape other than a 

rectangle). 

d. In the Available Borders list, click the border you want. 

Add a custom border  
You can create a custom border from clip art, a picture file, a scanned photograph or 

other bitmap, or a picture that you created in a drawing program. Your custom border 

will be stored with the Office Publisher 2007 border art.  

Note: The picture file that you use for a custom border must be smaller then 64 KB in 

size and must not include any text. 

e. Click BorderArt. 

f. In the BorderArt dialog box, click Create Custom. 
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g. In the Create Custom Border dialog box, to add a picture from a file that is 

located on your computer's hard disk without adding it to the Microsoft Clip 

Organizer, clear the Use Clip Organizer to select the picture check box. 

h. Click Select Picture. 

i. In the Insert Picture dialog box, browse to the location that contains the picture 

you want, click the picture, and then click Insert. 

j. In the Name Custom Border dialog box, type a name for your custom border, 

and then click OK. 

If the file size of the picture that you select is too large (greater than 64 KB), or if 

the picture contains text, you may receive an error message, and the border may 

not be created. If this occurs, repeat step 2 through step 5 to select a picture that 

has a smaller file size. 

Prepare, publish, and maintain your Publisher Web site 

Note: Web publications are only available in Publisher 2007 and earlier.  

After you plan and create a Web publication in Microsoft Office Publisher 2007, you can publish 

it to the web, a network server, or a shared folder on your own computer. Whatever the 

destination, Publisher creates filtered HTML files from the Web publication. You can open and 

read these HTML files in any Web browser, such as Windows Internet Explorer. 

 

In this article 

This article covers the procedures for creating and publishing your Web publication as HTML 

files and for updating your website by editing the Web publication and republishing it. 

 Prepare your website  

 Publish your website  

 Maintain your website  


